Making a Simple Screen

With weMX Designer, users can easily make a screen, and check the results through simulations

 

Run weMX Designer, and go to [File] – [New] – [New Project].

After the New project window appears, set the Project Name, Model Name, and Orientation

Set the screen’s resolution and name

Move to screen 1 to select [Draw] – [String], or click the [T shaped icon] on the top toolbar

Drag on the screen to create a text box.

Enter “Hello, World” in the text dialogue.

With the same process, lines, rectangles, and circles can be created.

 Select [Part] – [Switch/Lamp] – [Bit Switch], or click the [blue switch icon] on the top toolbar.

Drag on the screen to create a bit switch.

When the switch is touched, the set address’ value will be changed to an action set by the user (bit on/off, bit invert, etc.)

Select [Part] – [Data Display] – [Numeric Display], or click the [Numeric Display icon] on the top toolbar.

Drag on the screen to create a numeric display

The numeric display reads the set address’ data, and displays the results in dec, or hex form.

Completed screen will be saved as a HMX Project.

 

If the screen is finished, you can run a simulation to check if your screen works as intended.

Select [Project] – [Simulation], or click [Simulation icon] on the top toolbar to check the result.